Excel это не сложно
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?
27.06.2019, 05:22:08

Войти
Хотите поблагодарить участника за дельный совет? Нажмите [Повысить]. Так вы заслуженно поднимите репутацию активному участнику.
30 193 Сообщений в 4 780 Тем от 7 068 Пользователей
Последний пользователь: crinsawol
*
Перейти на сайт Хитрости Надстройка MulTEx Обучающие тренинги Наша группа ВКонтакте
Правила форума Начало Помощь Поиск Календарь Войти Регистрация Выйти
+  Excel это не сложно
|-+  Основные форумы
| |-+  Вопросы по Excel и VBA
| | |-+  Максимальное суммарное кол-во в группе и название группы
Страниц: [1]   Вниз
Печать
Автор Тема: Максимальное суммарное кол-во в группе и название группы  (Прочитано 146 раз)
0 Пользователей и 1 Гость смотрят эту тему.
andrey135
Новичок
*

Репутация: +0/-0
Офлайн Офлайн

Сообщений: 34


Просмотр профиля E-mail
« : 10.06.2019, 06:32:55 »

Добрый день. Прошу помочь/дать совет. Требуется подсчитать максимальное суммарное кол-во в группе и вывести название данной группы. Суммарный максимум нужно искать среди тех групп в которые входит не менее двух товаров. Решение нужно с помощью формулы массива.
« Последнее редактирование: 10.06.2019, 09:23:32 от vikttur » Записан
vikttur
Глобальный модератор
Ветеран
*****

Репутация: +110/-0
Офлайн Офлайн

Сообщений: 1 613



Просмотр профиля
« Ответ #1 : 10.06.2019, 09:29:06 »

Код: (vb)
=МАКС(СУММЕСЛИ(B5:B13;B5:B13;C5:C13))
=ИНДЕКС(B5:B13;ПОИСКПОЗ(МАКС(СУММЕСЛИ(B5:B13;B5:B13;C5:C13));СУММЕСЛИ(B5:B13;B5:B13;C5:C13);0))

Записан
andrey135
Новичок
*

Репутация: +0/-0
Офлайн Офлайн

Сообщений: 34


Просмотр профиля E-mail
« Ответ #2 : 10.06.2019, 10:13:20 »

большое спасибо, такое решение не совсем подходит, оно считает максимум по всем группам, а нужно только по тем группам  в которых товаров больше 1. Если в примере заменить в группе Б кол-во на 5000, оно его подтягивает, хотя не должно т.к. в группе Б 1 товар.
« Последнее редактирование: 10.06.2019, 10:26:48 от andrey135 » Записан
andrey135
Новичок
*

Репутация: +0/-0
Офлайн Офлайн

Сообщений: 34


Просмотр профиля E-mail
« Ответ #3 : 11.06.2019, 22:57:51 »

Можно закрывать тему решение получилось
=МАКС(СУММЕСЛИ($B$5:$B$13;B5:B13;$C$5:$C$13)*(СЧЁТЕСЛИ($B$5:$B$13;B5:B13)>1))
=ИНДЕКС(B5:B13;ПОИСКПОЗ($E$5;СУММЕСЛИ($B$5:$B$13;B5:B13;$C$5:$C$13)*(СЧЁТЕСЛИ($B$5:$B$13;B5:B13)>1);0);1)
Записан
vikttur
Глобальный модератор
Ветеран
*****

Репутация: +110/-0
Офлайн Офлайн

Сообщений: 1 613



Просмотр профиля
« Ответ #4 : 11.06.2019, 23:20:18 »

Правильнее:
=МАКС(ЕСЛИ(СЧЁТЕСЛИ($B$5:$B$13;B5:B13)>1;СУММЕСЛИ($B$5:$B$13;B5:B13;$C$5:$C$13)))
Так отрезаются лишние вычисления
Записан
Страниц: [1]   Вверх
Печать
Перейти в:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006-2011, Simple Machines Valid XHTML 1.0! Valid CSS!
Яндекс.Метрика Рейтинг@Mail.ru