Excel это не сложно
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
28.02.2024, 16:01:50

Войти
Хотите поблагодарить участника за дельный совет? Нажмите [Повысить]. Так вы заслуженно поднимите репутацию активному участнику.
33 221 Сообщений в 5 451 Тем от 6 738 Пользователей
Последний пользователь: asker
*
Перейти на сайт Хитрости Надстройка MulTEx Обучающие тренинги Наша группа ВКонтакте
Правила форума Начало Помощь Поиск Календарь Войти Регистрация Выйти
+  Excel это не сложно
|-+  Основные форумы
| |-+  Вопросы по Excel и VBA
| | |-+  Заполнение списка по исходным данным при наличии пустых ячеек
Страниц: [1]   Вниз
Печать
Автор Тема: Заполнение списка по исходным данным при наличии пустых ячеек  (Прочитано 5473 раз)
0 Пользователей и 1 Гость смотрят эту тему.
нгв1607
Новичок
*

Репутация: +0/-0
Офлайн Офлайн

Сообщений: 1


Просмотр профиля E-mail
« : 03.08.2011, 13:09:04 »

Привет форумчанам.
Проблема в следующем - есть исходный лист, выгруженный из 1С с имеющимися пустыми ячейками. Надо исходные данные с  привести к виду списка, с которым можно работать в сводной таблице поиском ВПР из Исходного листа и другими формулами. Этот Список создается на другом листе
На листе Список в столбце А (зеленый) надо создать нумерацию строк из столбца А на листе Исходный (красный) так, чтобы не было пустых строк в Списке. Т.е 1.2.3... по порядку.
Остальные данные планирую получать поиском ВПР относительно данных в столбце А.
Подкиньте идею, плиз, не могу сообразить какой формулу поставить начиная от ячейки А4 и вниз.
Записан
vikttur
Глобальный модератор
Ветеран
*****

Репутация: +124/-0
Офлайн Офлайн

Сообщений: 1 816



Просмотр профиля
« Ответ #1 : 12.08.2011, 09:27:27 »

Формула А3 листа Список:
Код:
=ЕСЛИ(СТРОКА(1:1)>МАКС(Исходный!$A$2:$A$15);"";СТРОКА(1:1))
Формула А2 листа Исходный:
Код:
=ЕСЛИ(C2<>"";МАКС($A$1:A1)+1)

Записан
Страниц: [1]   Вверх
Печать
Перейти в:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006-2011, Simple Machines Valid XHTML 1.0! Valid CSS!
Яндекс.Метрика Рейтинг@Mail.ru