Главная » Функции Excel »

Логические функции

  • И(AND) - возвращает значение ИСТИНА, если все аргументы имеют значение ИСТИНА.
    =И(логическое_значение1; логическое_значение2; ...)

    Логическое_значение1, логическое_значение2, ... - проверяемые условия, которые имеют значение ИСТИНА(TRUE) или ЛОЖЬ(FALSE), или выражение, которое возвращает такое(логическое) значение.
    Если аргумент содержит текст или пустые ячейки, то такие значения игнорируются.
    Если указанный массив/диапазон не содержит логических значений, то функция возвращает значение ошибки #ЗНАЧ!(#VALUE!)
    И(ИСТИНА; ИСТИНА) будет равно ИСТИНА
    =И(ИСТИНА; ЛОЖЬ) будет равно ЛОЖЬ
    =И(2+2=4; 2+3=5) будет равно ИСТИНА
    =И(A1:A4)если A1 и A3 равно ИСТИНА, а A2 равно ЛОЖЬ функция вернет ЛОЖЬ
    =И(1<A1; A1<10) если ячейка A1 содержит число больше 1 и меньше 10, то функция вернет ИСТИНА. В противном случае ЛОЖЬ

  • ЛОЖЬ(FALSE) - предназначена для вставки на лист логического значения ЛОЖЬ или использовании его напрямую в формулах.
    =ЛОЖЬ()
    =FALSE()

    Можно непосредственно ввести слово ЛОЖЬ(FALSE) в ячейку или в формулу, и Excel будет воспринимать его как логическое значение ЛОЖЬ.

  • ЕСЛИ(IF) - Выполняет проверку заданного условия и возвращает логическое ИСТИНА(), если условие выполняется и логическое ЛОЖЬ, если не выполняется. Чаще всего применяется для проверки наличия значений в ячейках или выполнения определенных условий в формулах(поиск значений, наличие ошибок и т.п.)
    =ЕСЛИ(лог_выражение;значение_если_истина; значение_если_ложь)
    Лог_выражение - значение или выражение, которое при вычислении дает логическое ИСТИНА или ЛОЖЬ.
    Значение_если_истина - значение, которое возвращается, если лог_выражение имеет значение ИСТИНА. Если лог_выражение имеет значение ИСТИНА и значение_если_истина опущено, то возвращается значение ИСТИНА. Значение_если_истина может быть другой формулой.
    Значение_если_ложь - это значение, которое возвращается, если лог_выражение имеет значение ЛОЖЬ. Если лог_выражение имеет значение ЛОЖЬ и значение_если_ложь опущено, то возвращается значение ЛОЖЬ. Значение_если_ложь может быть другой формулой.
    =ЕСЛИ(A2=10;СУММ(B2:G2);"")
    В данном случае, если значение ячейки A2 равняется 10, то будет вычислена формула СУММ(B2:G2) и функция ЕСЛИ вернет сумму этих ячеек(B2:G2). Если значение ячейки A2 отличается от 100, то функция вернет пусто.
    Еще один пример использования: предположим, что в ячейках A2:A4 записаны данные по фактическим расходам за январь, февраль, март: 2000, 2500 и 1500. В ячейках B2:B4 записаны данные по планируемым расходам за те же периоды: 1900, 2900 и 1400.
    При помощи ЕСЛИ можно проверить превышают ли фактические расходы планируемые:
    =ЕСЛИ(A2>B2;"Превышение расхода";"OK") функция вернет "Превышение расхода"
    =ЕСЛИ(A3>B3;"Превышение расхода";"OK") функция вернет "OK"
    =ЕСЛИ(A4>B4;"Превышение расхода";"OK") функция вернет "Превышение расхода"

  • НЕ(NOT) - Меняет логическое значение заданного аргумента на противоположное. Используется в случаях, когда необходимо быть уверенным в том, что значение не равно некоторой конкретной величине.
    =НЕ(логическое_значение)
    Логическое_значение - значение или выражение, которое при вычислении дает логическое ИСТИНА или ЛОЖЬ. Если логическое_значение имеет значение ЛОЖЬ, то функция вернет значение ИСТИНА. Если логическое_значение имеет значение ИСТИНА, то функция вернет ЛОЖЬ.
    =НЕ(ЛОЖЬ) равно ИСТИНА
    =НЕ(2*2=4) равно ЛОЖЬ

  • ИЛИ(OR) - возвращает значение ИСТИНА, если хотя бы один аргумент имеет значение ИСТИНА. Возвращает ЛОЖЬ, если все аргументы имеют значение ЛОЖЬ.
    =ИЛИ(логическое_значение1;логическое_значение2; ...)
    Логическое_значение1, логическое_значение2, ... - проверяемые условия, которые имеют значение ИСТИНА(TRUE), ЛОЖЬ(FALSE), или выражение, которое возвращает такое(логическое) значение.
    Если аргумент содержит текст, пустые ячейки или ошибки, то такие значения игнорируются.
    Если указанный массив/диапазон не содержит логических значений, то функция возвращает значение ошибки #ЗНАЧ!(#VALUE!)
    =ИЛИ(ИСТИНА) равняется ИСТИНА
    =ИЛИ(1+1=1;2+2=5) равняется ЛОЖЬ
    =ИЛИ(A1:A3) будет равно ИСТИНА, если ячейки A1:A3 содержат значения ИСТИНА, ЛОЖЬ, ИСТИНА

    Функцию ИЛИ можно использовать для проверки нахождения в диапазоне/массиве значения. Например, в ячейках A1:A3 записаны значения: word, excel, outlook. Чтобы определить, содержится ли в этих ячейках слово excel, необходимо записать функцию ИЛИ
    =ИЛИ(A1:A3="excel")
    При этом записывать функцию необходимо как формулу массива. Т.е. после записи функции ввод в ячейку необходимо завершать нажатием сразу трех клавиш CTRL+SHIFT+ENTER. Подробнее про формулы массива >>

  • ИСТИНА(TRUE) - предназначена для вставки на лист логического значения ЛОЖЬ или использовании его напрямую в формулах.
    =ИСТИНА()
    =TRUE()

    Можно непосредственно ввести слово ИСТИНА(TRUE) в ячейку или в формулу, и Excel будет воспринимать его как логическое значение ИСТИНА.

Статья помогла? Сделай твит, поделись ссылкой с друзьями!

Тренинги

Заказать
Наши партнеры
Перейти
Перейти
Счетчики
Анализ сайта

Яндекс.Метрика
© 2017 Excel для всех  Войти
Авторизация
*
*
Регистрация
*
*
*
Пароль не введен
*
captcha
Генерация пароля